Wednesday, December 08, 2010

updated instructions for windows users (still no package)

I tryied to make the msn backend work on windows and I updated the instructions on the readme in emesene.

the new stuff is related to the papyon backend for msn that now is the only supported backend and has some dependencies (OpenSSL, pyCrypto) and those need to be installed.

to make both instructions similar I recommend that you download and install msysgit from here:

http://code.google.com/p/msysgit/

and follow the instructions from here:

http://emesene-msn.blogspot.com/2010/10/instructions-for-testers.html

until you downloaded emesene code and updated the submodules, then follow the instructions in the INSTALL_WINDOWS.txt file here is an updated version:


https://github.com/marianoguerra/emesene/blob/master/INSTALL_WINDOWS.txt

I got emesene to run using papyon with this setup but the portable version gave me protocol error, if you can find the way to fix it it would be great.

still waiting for packages...

EDIT: I forgot to add one instruction, before running python setup.py py2exe you need to copy the papyon folder that is in emesene/emesene/e3/papylib/papyon/papyon to emesene/emesene/papyon, something like:

cp -r emesene/emesene/e3/papylib/papyon/papyon emesene/emesene/

to avoid the import error trying to load papyon.

8 comments:

Caio said...

Ok, i'll try to work on it. But i'm getting some error with libraries, because my system is broken, but, anyway, i'll try.

Radial said...

Well I`m still trying (First time with Python) and the error I get is; ImportError: No module named papyon

Till now no clue where to go.

siz said...

I managed to create both the installer and the portable packages, but when I test it I keep getting "Protocol Error"

luismarianoguerra said...

@Radial: see the edition I made to the post :)

Radial said...

@luismarianoguerra thanks, that dit the trick! It compiled without any error.
Installation went also perfect, just the login. I got the same error as siz: Protocol Error.

luismarianoguerra said...

since the protocol error only happens when the py2exe package is made I think this is a bug in papyon.

can someone contact the papyon guys to get some hints?

siz said...

I don't know if this can help anyone, as I don't know python myself, but in the logs I see
[18:58:21 ERROR papyon.service] Couldn't build or process SOAP response

and

[18:58:01 ERROR papyon.service] SOAP Parse Error: invalid xml+soap data

Note:I have Papyon 0.54 installed

Andrade said...

Hola gente hace unos días que estoy usando el emesene.
Y me parece el mejor cliente de msn que he usado.
La última version que probé fue la v1.0.1 (probe anteriores también) y ha mejorado MUUUUCHO la 1.6 que es a la que salté ahora.
Estaba usando aMSN, y la verdad ya estaba recontra podrido de que falle mucho peor que la peor escopeta de feria. Que error de GTK todo el tiempo... que es muy lento... empecé a usar versiones SVN y peor todavía.
Me había acostumbrado a algunas power features y por eso no quería cambiar.
Todo esto en windows, no se realmente si aMSN es una maravilla en los unix.

Me parece perfecto, simple como para que lo use la abuelita que no sabe nada de computación y con opciones configurables poderosas para los que saben.




Puse mi opinión en un foro:
"si andan con ganas de probar otro mensajero les recomiendo el emesene.

Anda muy muy bien. Rápido, cómodo, con funciones extra copadas. Tiene un "plus" integrado que no hay que instalar ningún parche raro ni dudoso de virus y esas cosas, y lo tiene siempre, no hay que esperar que salga el parche de la nueva versión.
Es multicuentas de movida, sin parches.
Tiene un modo NINJA, si :D
Esta para el OS que te imagines (windou, macos, gnu/linux)
Es rápido y fácil de configurar, incluso las opciones avanzadas. Es bastante lindo.
FUNCIONA.

Y además es ARGENTINO!"


Mucha forza, sigan con el excelente trabajo que estan haciendo.

Disculpen si este no era el lugar para esto.